J2SE 1.4 Applet:

NOTE1: Applet version could run only in appletviewer (due applet's security restrictions)!
NOTE2: Applet version could use only default dictionary file!